Install Driver Epson L3110 Printer On Ubuntu 20.04.2 LTS

In This tutorial, we will describe how to install Epson L3110 Printer On Ubuntu 20.04.2 LTS

First. Find driver Epson for linux on this link: Epson Download Center or Epson Printer Utility.
After download it.

Find Selected printer driver below :

L3110 SeriesPrinter DriverLinux1.7.16ESC/P-R Driver (generic driver)All language08-04-2021

Open Linux terminal and go to directory there are driver epson. Type command :

If not or any error and lsb not installed

dpkg: error processing package epson-inkjet-printer-escpr (–install):
dependency problems – leaving unconfigured
Processing triggers for libc-bin (2.27-3ubuntu1.4) …
Errors were encountered while processing:
epson-inkjet-printer-escpr

then run this command :

This command automatic repair or install dependent software requirement.

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
linux-hwe-5.4-headers-5.4.0-42 linux-hwe-5.4-headers-5.4.0-72 linux-hwe-5.4-headers-5.4.0-73 linux-hwe-5.4-headers-5.4.0-74 python3-click python3-colorama
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
alien at autoconf automake autopoint autotools-dev build-essential debhelper debugedit dh-autoreconf dh-strip-nondeterminism dpkg-dev fakeroot g++ g++-7 gcc gcc-7
libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libarchive-cpio-perl libasan4 libatomic1 libc-dev-bin libc6-dev libcilkrts5 libfakeroot
libfile-stripnondeterminism-perl libgcc-7-dev libgsasl7 libitm1 libjpeg62 libkyotocabinet16v5 liblsan0 libltdl-dev liblua5.2-0 libmail-sendmail-perl libmailutils5
libmpx2 libmysqlclient20 libntlm0 libquadmath0 librpm8 librpmbuild8 librpmio8 librpmsign8 libsigsegv2 libstdc++-7-dev libsys-hostname-long-perl libtool libtsan0
libubsan0 linux-libc-dev lsb lsb-core lsb-invalid-mta lsb-printing lsb-security m4 mailutils mailutils-common make manpages-dev mysql-common ncurses-term pax
po-debconf rpm rpm-common rpm2cpio
Suggested packages:
autoconf-archive gnu-standards autoconf-doc dh-make dwz rpm-i18n debian-keyring g++-multilib g++-7-multilib gcc-7-doc libstdc++6-7-dbg gcc-multilib flex bison
gcc-doc gcc-7-multilib gcc-7-locales libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan4-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg
libmpx2-dbg libquadmath0-dbg glibc-doc libtool-doc libstdc++-7-doc gfortran | fortran95-compiler gcj-jdk m4-doc mailutils-mh mailutils-doc make-doc libmail-box-perl
python elfutils rpmlint rpm2html
The following NEW packages will be installed:
alien at autoconf automake autopoint autotools-dev build-essential debhelper debugedit dh-autoreconf dh-strip-nondeterminism dpkg-dev fakeroot g++ g++-7 gcc gcc-7
libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libarchive-cpio-perl libasan4 libatomic1 libc-dev-bin libc6-dev libcilkrts5 libfakeroot
libfile-stripnondeterminism-perl libgcc-7-dev libgsasl7 libitm1 libjpeg62 libkyotocabinet16v5 liblsan0 libltdl-dev liblua5.2-0 libmail-sendmail-perl libmailutils5
libmpx2 libmysqlclient20 libntlm0 libquadmath0 librpm8 librpmbuild8 librpmio8 librpmsign8 libsigsegv2 libstdc++-7-dev libsys-hostname-long-perl libtool libtsan0
libubsan0 linux-libc-dev lsb lsb-core lsb-invalid-mta lsb-printing lsb-security m4 mailutils mailutils-common make manpages-dev mysql-common ncurses-term pax
po-debconf rpm rpm-common rpm2cpio
0 upgraded, 70 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 37,1 MB of archives.
After this operation, 148 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Y

….

Setting up lsb-printing (9.20170808ubuntu1) …
Setting up lsb (9.20170808ubuntu1) …
Setting up epson-inkjet-printer-escpr (1.7.16-1lsb3.2) …
Processing triggers for ureadahead (0.100.0-21) …
ureadahead will be reprofiled on next reboot
Processing triggers for install-info (6.5.0.dfsg.1-2) …
Processing triggers for libc-bin (2.27-3ubuntu1.4) …
Processing triggers for systemd (237-3ubuntu10.50) …
Processing triggers for man-db (2.8.3-2ubuntu0.1) …
mit@mit-uinmalang:~$

Finish Successfull install for dependent software for epson printer

Second. Printer Installation.

Install printer, Click Bar Menu below and type “printer” in search bar.

Don’t forget connect your computer with epson printer.

Click Add printer. If printer cable connect to your computer, system automatic detect printer and will intall it.

Third. If it’s successfully. May check using “printer test page”. you can show figure below :

Good luck may Allah bless you.

Leave a Reply

Your email address will not be published. Required fields are marked *